[libxml++] Node's xpath methods



Node now has

  std::string get_path() const;

Should we rename this to get_xpath()?


Also, maybe we should rename 

 NodeSet find(const std::string& xpath) const;

to find_by_xpath() or something similar? find() seems a bit generic,
particularly when it just takes std::string which is also very generic.

Does anyone know what this stuff is called in other XML parser APIs?
Xerces-C++ doesn't seem to have any xpath stuff.

-- 
Murray Cumming
murray usa net
www.murrayc.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]