Re: [gupnp] GUPnP 0.14.1 (stable) & GUPnP 0.15.0 (unstable)

On Fri, Dec 3, 2010 at 1:11 PM, Zeeshan Ali (Khattak) <zeenix gmail com> wrote:
> Hi Peter,
> On Thu, Dec 2, 2010 at 8:30 PM, Peter Robinson <pbrobinson gmail com> wrote:
>> On Thu, Dec 2, 2010 at 6:21 PM, Zeeshan Ali (Khattak) <zeenix gmail com> wrote:
>>> Hi Peter,
>>> On Thu, Dec 2, 2010 at 6:20 PM, Peter Robinson <pbrobinson gmail com> wrote:
>>>> It seems we have a new release of gupnp-av in both the 0.6 and 0.7
>>>> branches that's not been announced yet.
>>>   You didn't get the mail about that? I just checked and it seems I
>>> did send the announcement mail to this mailing list.
>>>> 0.7 release built fine on
>>>> rawhide but it seems 0.6.3 has a regression over previous 0.6.1 stable
>>>> releases in the detection of gobject-introspection. Everything is
>>>> identical to when I built  0.6.1.
>>>> Build log is:
>>>  Sorry but you could help me by pointing out the exact error. The one
>>> that I could find is this one and it doesn't tell me enough to figure
>>> out whats going wrong:
>> Its not detecting gobject-introspection in configure and is hence not
>> enabling it. The lack of the file at the end is just the end result of
>> that. I'm not sure if the version requirements of go-i have changed
>> (which they shouldn't in a minor release) or something else because
>> the configure script doesn't say why its not but I checked and the
>> go-i-devel package is installed.
>  Oh, you are going directly from 0.6.1 to 0.6.2. Which is
> understandable since I had forgotten to announce 0.6.2 (so sorry for
> that). :( Anywhere, here is the log of 0.6.2 that answers your
> question:

Oh. I wondered what happened to the interim release, I'd assumed that
it has issues. I personally don't believe that the requirements should
change during a minor release. I now have the problem that Fedora 14
is stuck on 0.6.1 as it has go-i 0.9.3 and I don't see that changing
and we don't get the bugfixes that 0.6.2 and later offers, and if we
end up with a security issue I'll need to backport that fix directly.
No ideal.

To unsubscribe send a mail to gupnp+unsubscribe\

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]