Re: Installing gtranslator


I am not able to fulfill the libpeas dependency for gtranslator. After
executing in a jhbuild shell

  ./configure --prefix=/opt/gnome --libdir=/opt/gnome/lib64

in the gtranslator directory, it returns the following error:

    Requested 'libpeas-1.0 >= 0.7.0' but version of libpeas is 0.5.5 
    Requested 'libpeas-gtk-1.0 >= 0.7.0' but version of libpeas-gtk is 0.5.5

    Consider adjusting the PKG_CONFIG_PATH environment variable if you installed
    software in a non-standard prefix.

    Alternatively, you may set the environment variables GTRANSLATOR_CFLAGS and
    GTRANSLATOR_LIBS to avoid the need to call pkg-config.  See the pkg-config man
    page for more details.

For installing libpeas I did the following:

 1) ./configure --prefix=/opt/gnome --libdir=/opt/gnome/lib64
 2) make
 3) make install

Though, after running `make install' I get the folllowing error:

    libtool: install: error: cannot install `' to a directory
    not ending in /opt/gnome/lib
    make[2]: *** [install-libLTLIBRARIES] Error 1
    make[2]: Leaving directory `/home/kenny/Source/gnome/libpeas/libpeas-gtk'
    make[1]: *** [install-am] Error 2
    make[1]: Leaving directory `/home/kenny/Source/gnome/libpeas/libpeas-gtk'
    make: *** [install-recursive] Error 1

Do you have a workaround?

Encouraging respectful discussion with OpenRespect (

Attachment: pgp3IJTh83aZO.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]