ANNOUNCE: gtkmm 2.90.7



*** gtkmm 2.90:

gtkmm 2.90 wraps GTK+ 2.90. It is the gtkmm-3.0 ABI and installs in parallel 
with the gtkmm-2.4 ABI, of which gtkmm 2.20 is currently the latest stable version.
This allows application developers to start using it when they choose to, 
without being forced, and without breaking existing installed applications.

gtkmm-3.0 will be mostly API-compatible with gtkmm-2.4, though some small 
changes will be needed in application source code.

The decision to do this ABI-break was not ours. We are forced to do it by GTK+'s 
decision to do a ABI-breaking GTK+ 3.0. However, we will take the 
opportunity to fix some small issues.

Note that there is also a gtkmm 2.21 (to become 2.22) version, which has small API additions.

gtkmm stays in-sync with GTK+ by following the official GNOME release schedule:
http://www.gnome.org/start/unstable/

Bindings for the rest of the GNOME Platform are also available, and are also 
API-stable.

http://www.gtkmm.org


*** Changes

2.90.7 (unstable):

Gdk:
* Bitmap: Remove the constructors. This whole class may be removed soon,
* Color: Remove rgb_find_color().
* Cursor: Added get_cursor_type().
* Device:
  - Added get_key(), get_axis_use(), get_n_axes(),
	get_axis_value(), get_display(), get_associated_device(), get_device_type(),
	grab(), ungrab().
  - get_key(): Make this const.
* Display: Added device_is_grabbed(), get_device_state(),
	get_window_at_device_position(), warp_device(), set_device_hooks(),
	get_device_manager()
* Added DeviceManager.
* Drawable: Removed draw_*() methods. We should use cairo now instead.
* Pixbuf:
  - Added constructor (and create) that takes a Cairo::Surface.
  - Removed constructors and create*() methods that took a Gdk::Image.
* Pixmap: Remove some constructors. This whole class may be removed soon.
* Removed RgbCmap.
* Window: Added set_device_cursor(), get_device_position(),
	get_device_events(), set_device_events(), get_support_multidevice(),
	set_support_multidevice(), get_composited(), is_input_only(), is_shaped(),
  has_native(), get_modal_hint(), get_background_pattern(),
  coords_to_parent(), coords_from_parent(),
  get_effective_parent(), get_effective_toplevel(), create_similar_surface(),
  get_accept_focus(), get_focus_on_map().
  (Murray Cumming)
* Gdk::Cairo: set_source_pixmap(): Added default parameter values
  for pixmap_x and pixmap_y.

Gtk:
* AboutDialog: Added get/set_license_type().
* Added Application, wrapping GtkApplication.
* Removed AnchorType enum.
* CellView: Added get_desired_width_of_row() and
  get_desired_height_for_width_of_row().
* Dialog:
  - Remove get/set_has_separator() and property.
  - Constructors: Remove use_separator parameters.
* Expander: Added get/set_label_fill() and property.
* FileChooserButton: Remove the constructor that lets us set
  the backend.
* IconInfo: Added load_icon_symbolic().
* IconView: Rename get/set_orientation() (and property) to
  get/set_item_orientation().
* Image: Removed get_image() and set(Gdk::Image).
* Removed Item, replaced by use of MenuItem.
* MenuItem: Added unset_submenu().
* MenuShell: Removed items() and the MenuHelper namespace.
* MessageDialog: Removed the buttons property.
* Notebook:
  - Added get_tab_hborder() and get_tab_vborder().
  - Removed Notebook::pages().
* PaperSize: Added get_paper_sizes().
* ProgressBar:
  - Added get/set_inverted() and get/set_show_text().
  - Remove get/set_orientation(), deriving from Orientable instead.
* PrintOperation: Added run_page_setup_dialog() overloads
  with no PageSetup parameter.
* PrintUnixDialog: Added get_manual_capabilities().
* RadioAction: Added join_group().
* RecentManager: Removed get/set_limit() and the property.
  RecentChooser still has these.
* Added SizeRequest.
* StatusBar: Rename remove_all() to remove_all_messages().
* StatusIcon:  Removed get/set_blinking().
* Style:
  - Removed get*_gc() and paint_polygon().
  - Added copy().
* Table:
  - Removed children(). This used API in GTK+ that has been removed.
  - Added get_size().
* Viewport: Added get_view_window().
* Widget:
  -  Added device_is_shadowed(), set_device_events(),
  add_device_events(), set/get_support_multidevice(), get_device_event().
  - Added send_focus_change().
  - Added const version of get_accessible().
* Added WrapBox.
  (Murray Cumming)

General:
* Windows build fixes.
  (Armin Burgmeier)
* API reference documentation improvements.
  (Murray Cumming)

*** Development 

There is active discussion on the mailing list: 
http://www.gtkmm.org/mailinglist.shtml
and in the #c++ channel on irc.gnome.org


-- 
Murray Cumming
murrayc murrayc com
www.murrayc.com
www.openismus.com












[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]