Re: [gtkmm] pack_start and AttachOptions is still confusing



Actually I was thinking EXPAND_WIDGET would be (true, true) (the default) and EXPAND_PADDING would be (true, false). Right? Any ideas for better names? EXPAND_CHILD instead of EXPAND_WIDGET?


I'd prefer Gtk::SHRINK      for (false, false),
           Gtk::EXPAND      for (true, false),
           Gtk::EXPAND_FILL for (true, true)

or

           Gtk::SHRINK         for (false, false),
           Gtk::EXPAND_PADDING for (true, false),
           Gtk::EXPAND_FILL    for (true, true)

if the native english speakers on the list agree about the proper
meaning of "padding". "Child" or "widget" in EXPAND_CHILD / EXPAND_WIDGET
add no meaning at all and just result in longer expressions.

It distinguishes what the box is EXPANDing the space with, blank space (PADDING) or the child WIDGET itself. FILL to me is ambiguous, fill with what?


--
Michael Babcock
Jim Henson's Creature Shop





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]