Re: [gtkmm] pack_start and AttachOptions is still confusing



Murray Cumming wrote:

I propose a single, non-ORable enumeration that accurately reflects the possible packing options, perhaps something like:

SHRINK - Shrink space to widget's size request.
EXPAND_PADDING - Expand space with padding around widget.
EXPAND_WIDGET - Expand space by expanding the widget size.


I like the idea.

So is this correct?:
SHRINK would be Gtk::SHRINK (or false, false)
EXPAND_PADDING would be Gtk::EXPAND | Gtk::FILL (or true, true) (the default)
EXPAND_WIDGET would be Gtk::EXPAND (true, false)

Actually I was thinking EXPAND_WIDGET would be (true, true) (the default) and EXPAND_PADDING would be (true, false). Right? Any ideas for better names? EXPAND_CHILD instead of EXPAND_WIDGET?

This seems to apply to Table::attach also. There, Gtk is already using its AttachOptions enum, so our new "AttachOptions" wouldn't be just a wrapper of that. Perhaps we should change the name for less confusion.

--
Michael Babcock
Jim Henson's Creature Shop





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]