Re: [gtkmm] pack_start and AttachOptions is still confusing



Am 12.07.2002 18:58 schrieb(en) Michael Babcock:
Murray Cumming wrote:

I propose a single, non-ORable enumeration that accurately reflects the possible packing options, perhaps something like:

SHRINK - Shrink space to widget's size request.
EXPAND_PADDING - Expand space with padding around widget.
EXPAND_WIDGET - Expand space by expanding the widget size.


I like the idea.

So is this correct?:
SHRINK would be Gtk::SHRINK (or false, false)
EXPAND_PADDING would be Gtk::EXPAND | Gtk::FILL (or true, true) (the default)
EXPAND_WIDGET would be Gtk::EXPAND (true, false)

Actually I was thinking EXPAND_WIDGET would be (true, true) (the default) and EXPAND_PADDING would be (true, false). Right? Any ideas for better names? EXPAND_CHILD instead of EXPAND_WIDGET?

I'd prefer Gtk::SHRINK      for (false, false),
           Gtk::EXPAND      for (true, false),
           Gtk::EXPAND_FILL for (true, true)

or

           Gtk::SHRINK         for (false, false),
           Gtk::EXPAND_PADDING for (true, false),
           Gtk::EXPAND_FILL    for (true, true)

if the native english speakers on the list agree about the proper
meaning of "padding". "Child" or "widget" in EXPAND_CHILD / EXPAND_WIDGET
add no meaning at all and just result in longer expressions.

Regards,

  Martin



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]