Fwd: [Solved] Re: GtkTreeView does not show data after clear()

---------- Forwarded message ----------
From: David Lowrence <debmint49 gmail com>
Date: Tue, Dec 13, 2016 at 6:16 PM
Subject: [Solved] Re: GtkTreeView does not show data after clear()
To: Torsten Schoenfeld <kaffeetisch gmx de>

On Sun, Dec 11, 2016 at 1:45 PM, Torsten Schoenfeld <kaffeetisch gmx de> wrote:
On 26.11.2016 17:09, David Lowrence wrote:
> When the program runs, the data is displayed on the first pass, but
> on the second, it's not. I edited the program changing "Gtk3" to
> "Gtk2" and changed the version requirement in the Glade file, and the
> data displays on both passes.

I cannot reproduce this with perl 5.24.0, perl-GOI 0.040, perl-Gtk3
0.029, gobject-introspection 1.50.0 and gtk+ 3.22.4.  The tree view
displays the same three lines in both iterations.  What versions are you

The system on which I experienced the problem was under Debian Jessie.
This system has, of course somewhat older software. 
# perl -v
# perl -MGlib::Object::Introspection -E'say
# perl -MGtk3 -E'say $Gtk3::VERSION'
# pkg-config --modversion gobject-introspection-1.0
# pkg-config --modversion gtk+-3.
After doing further research and experimenting, I have concluded that my
problem probably lies with gobject introspection itself.  I tried similar code
with python and it, too exhibited the same problem.

Edit: Torsten Schoenfeld suggested the problem could be missing or incorrect annotations in gtk+....

Trying the perl scripts on Linux Mint (somewhat newer version but not the lastest)
also was problematic. When running them on Arch, with all the software at or above
the versions you have, the program performed without these problems.  So I've
concluded that it is, indeed, an issue with older software.

I am satisfied to call the issue solved, but it would be nice to know just what was going on.  I've tried several things, including specifying the text_column for the autocompletion, on each pass (If I didn't mention it, this was a ListStore for an autocompletion) and this didn't help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]