Re: Glib::Object::Subclass bug? or Misunderstanding?

On Mar 20, 2006, at 10:18 PM, James Muir wrote:

muppet wrote:

What upgrade was it? Was glib-2.0 upgraded without rebuilding Glib? There was a rash of "bugs" recently related to botched upgrades...

I can't reproduce this. I've tried

- Gnome2::Canvas 1.002.
- libgnomecanvas 2.6.0
- libgnomecanvas 2.11.1

- Glib 1.105
- Glib 1.120
- glib 2.4.8
- glib 2.10.2
Another error in communication on my part. I performed a clean install of Zenwalk 2.2.

I tried inserting the default GET_PROPERTY into the modules that use Glib::Object::Subclass and I got further. Some objects were displayed on the canvas, but I'm now getting:

*** unhandled exception in callback:
*** Can't locate object method "get_default_value" via package "Glib::Param::Boxed" at ../lib/Gtk2/Ex/MindMapView/ line 227.
*** ignoring at line 68.

That's because you can't specify a default value for a Boxed parameter type. The code in the XS implementation does the equivalent of "$pspec->can ('get_default_value') && return $pspec- >get_default_value". The documentation omits that for brevity and clarity. *cough*

If you're planning to use integer values for that property, use Glib::Param::Int instead.

and also I ran the Glib and Gtk2 regression tests. It looks to me like the "f.t" Glib test is confirming that I have problem with Glib::Object::Subclass. Maybe you can make more of it. Here's the Glib test results:


# Failed test 'and they have values'
# in t/f.t at line 111.
# Structures begin differing at:
# $got->[0] = undef
# $expected->[0] = 'Joe'

# Failed test 'and they have values'
# in t/f.t at line 168.
# Structures begin differing at:
# $got->[0] = undef
# $expected->[0] = 'Joe'
# Looks like you failed 2 tests of 42.
Test returned status 2 (wstat 512, 0x200)
DIED. FAILED tests 13, 42
Failed 2/42 tests, 95.24% okay

Please try with Glib 1.105. I would swear till i was blue in the face that this is a problem we fixed in the last couple of months, but i can't remember the details.

Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 112-137
Failed 26/137 tests, 81.02% okay

That's somewhat worrying...

Any suggestions on how to proceed with debugging this problem would be appreciated.

Try figuring out why the code is skipped. I can't give many more details because i can't reproduce it.

muppet <scott at asofyet dot org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]