Re: compilation error with Gtk-Perl-0.7009

Yasushi Okubo said:

I am trying to compile Gtk-Perl-0.7009 on redhat WS3.0 (or fedora core
1) through cpan, and see the following errors.   So, I manually download
tar.gz file and tried to compile it with :
perl Makefile.PL INC=/usr/include/gtk-1.2 or
perl Makefile.PL INC=`gtk-config --cflags`

But it also failed to compile source code with the same error message.

Please advise me what I can do from here.   I tried to search rpm,but it
only has an older version (0.7008).

(i'm pretty sure) the only fixes between 0.7008 and 0.7009 are build issues,
which apparently don't address the problems you're having. if you have rpms of
0.7008 then you might as well use them.

if you're developing new code you should use Gtk2-Perl
( rather than Gtk-Perl. if you're needing
Gtk-Perl as a dependacies the rpms are as good a way to go as any as it's
issues are primarily build related.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]