compilation error with Gtk-Perl-0.7009


I am trying to compile Gtk-Perl-0.7009 on redhat WS3.0 (or fedora core 1) through cpan, and see the following errors. So, I manually download tar.gz file and tried to compile it with :
perl Makefile.PL INC=/usr/include/gtk-1.2 or
perl Makefile.PL INC=`gtk-config --cflags`

But it also failed to compile source code with the same error message.

Please advise me what I can do from here. I tried to search rpm,but it only has an older version (0.7008).


=== error message ===

Found Gtk::Install::Files in /root/Gtk-Perl-0.7009/GdkPixbuf/../Gtk/../blib/arch/Gtk/Install/
Loading pkg.defs
Dir ||
gtktypexp.c:1:30: gtk/gtktypeutils.h: No such file or directory
gtktypexp.c: In function `main':
gtktypexp.c:9: `GSList' undeclared (first use in this function)
gtktypexp.c:9: (Each undeclared identifier is reported only once
gtktypexp.c:9: for each function it appears in.)
gtktypexp.c:9: `names' undeclared (first use in this function)
make: *** [GdkPixbuf/Makefile] Error 141

[root ferrari Gtk-Perl-0.7009]# locate gtk/gtktypeutils.h
[root ferrari Gtk-Perl-0.7009]# ls -ltr /usr/include/gtk-1.2/gtk/gtktypeutils.h -rw-r--r-- 1 root root 12286 Jun 16 14:16 /usr/include/gtk-1.2/gtk/gtktypeutils.h

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]