Re: Binding convention for poorly named functions

On Mon, 2004-03-15 at 22:43, muppet wrote:

  # as a static method (consistent with how we've done things in the past)
  Some::Naughty->function (other_object)

I think this would be a good compromise between "correct" and

To clarify:  There are not going to be many functions that need this
special treatment.  Most likely only some esoteric stuff in gdk, because
that's where most of the unbound API can be found -- besides pango, that
is, but pango has a very well designed API and I do not expect to find
problematic functions.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]