glib 1.2.9 will not compile

I have a G4 powerbook apple computer with a 1.0 GHz processor using mac os x 10.2.8 on Jaquar. I am trying to download GIMP. But before I can do this, I read that I need to download and install Glib and Gtk. I downloaded both glib 1.2.9 and gtk 1.2.9 and gimp 1.2.3. I was able to configure glib 1.2.9. I was also able to build glib 1.2.9. However, when I try to compile glib 1.2.9 I get the following error:

/bin/sh ./mkinstalldirs /usr/local/lib
/bin/sh ./libtool --mode=install /usr/bin/install -c /usr/local/lib/
/usr/bin/install -c .libs/libglib.lai /usr/local/lib/
/usr/bin/install: /usr/local/lib/ Permission denied
make[2]: *** [install-libLTLIBRARIES] Error 71
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

Does anyone know what this means and how do I fix it so that I can compile glib and move on to gtk and finally onto gimp?
Any help would be greatly appreciated.

Ronald Cross

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]