Re: Mozilla binding

On 01/27/01 Maher Awamy wrote:
Same results with http connections, I am using Mozilla from CVS - I was
suspecting the libs and linking at the end, when I change the order or add
-lpthread (necessary lib btw Paolo) then I get a seg sometimes too in unkown
addresses if I run it under the debugger, weird !

Well, I don't get SEGV, though gdb gets confused when dealing with the 
Linking with pthread didn't change anything, but it helped me recall
the problems a friend of mine had developing mod_dtcl (with threaded tcl)
for an unthreaded apache: it segfaulted or acted weirdly anyway.
So, first thing I tried compiling the module with a threaded perl
and.... dada! it works.
The other option is to LD_PRELOAD the libpthread library: this way
it works also for the normal unthreaded perl, but there are no
promises this'll work in the future or for other platforms 
(it's up to the libc/libpthread/mozilla maintainers to fix it or break 
it more:-)...

Anyway, happy Perl/Gtk/Mozilla hacking!


lupus debian org                                     debian/rules
lupus ximian com                             Monkeys do it better

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]