glib install problems

Hi list

I hope this is the appropriate list for this question, if not I'll
repost elsewhere.

I'm preparing the ground for install Gimp2.0, and am compiling the
dependencies that it requires. glib-2.4.0 appears to compile cleanly
with the standard ./configure && make && make install.

Now when I compile another package that has glib-2.4.0 as a dependency,
I get the following error during ./configure (in this case of

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from If GLIB is
*** but not in the same location as pkg-config add the location of the
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

>From what I can see, glib-2.4 hasn't installed itself in /usr/lib or
/usr/local/lib/. I'm at a loss as how to please pkg-config.

Any help much appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]