Re: glib install problems

M Hoskison wrote:
Now when I compile another package that has glib-2.4.0 as a dependency,
I get the following error during ./configure (in this case of

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from If GLIB is
*** but not in the same location as pkg-config add the location of the
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

From what I can see, glib-2.4 hasn't installed itself in /usr/lib or
/usr/local/lib/. I'm at a loss as how to please pkg-config.

As if the whole gtk/glib nightmare weren't confusing enough, glib-2.2 and glib-2.4 etc install themselves in directories named glib-2.0. That could be your problem.

I'm going through the same upgrades (for gimp 2) that you are now. I apparently had glib-2.2.3 installed at /usr/lib/, and when I installed 2.4 it went to /usr/local/lib/. So I deleted these (glib-2.3) files:


That made the error message go away. Of course, now none of my programs will start (rox (file manager), gftp, thunderbird, etc), and gtk+-2.4.0's make is dying with some obscure error, so my entire system is borked.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]