Re: [gtk-list] Solaris Help

>I am looking for any helpful information about installing gtk on Solaris
>(2.7).  Yesterday I downloaded gtk+1.1.13, and compiled it.  I received a
>*TON* of warning messages mostly to the effect of mis-referenced pointers,
>etc.  However, gtk did build, and  I installed it.  Next, I compiled
>gbuffy which yielded no errors, but it seg faults and dumps core whenever 
>I try to run it. I think that the problem is with my installation of gtk.
>If someone can give a pointer to Solaris pkgs of gtk, that would be great.
>Otherwise, I'd like to know if anyone has successfully compiled/installed
>gtk for Solaris, and if so, what requirements there where. Thanks in

i installed gtk 1.1.13 on a Solaris 2.6 system using egcs 1.1.1
the default configuration compiled ok, but dumped core.
after tracing down where it segfaultet (it was in gdk_init() during
the call to gdk_im_open())
i tried using the --enable-xim=no flag for configure
and this time it worked

Andre Fornacon      
phone: 49 89 74 73 77 52
TESIS GmbH Munich, Germany

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]