Re: check button MS-Windows style.




Adrian Feiguin <feiguin@magnet.fsu.edu> writes:

> > Adrian Feiguin <feiguin@magnet.fsu.edu> writes:
> > > Gtk+extra will have a checkbutton with that style called gtkcheckitem.
> > > gtk+extra will be released this week. Regards,
> > 
> > Encouraging this kind of gratuitously inconsistent look-and-feel seems
> > a bit silly, especially since this aspect of look-and-feel is already
> > user configurable.
> > 
> > It's a disservice to users to make them learn two interfaces.
> > 
> > I guess for in-house or for-personal-use apps it doesn't matter, but 
> > for any released app it's a terrible idea.
> > 
> > I call this gtk_ctree_set_expander_style() syndrome, and it must be
> > eliminated!
> >
> 
> I agree with you in many senses, but I still have something to argue. The
> people in gtk is dedicating a lot of time and effort to port the libraries
> to other plattforms (e.g, windows) and low-level stuff, and a lot of
> widgets have not been maintained anymore. 

If widgets are unmaintained its becuase nobody has stepped up to maintain
them.

> Example: gtkspinbutton. IMHO
> this widget must be re-written completelly from scratch as a gtkhbox
> subclass (like gtkcombo), and this will fix all the reparenting bugs it
> still has. 

No, the way to fix this (and the way that it will be fixed in 1.4) is
to change gtk_widget_reparent() to simply be a 

ref() / gtk_container_remove() / gtk_container_add() / unref()

> Suppouse that I write it, would you think it will replace the
> old one? I'm not sure. In case it isn't, should I include it in my libs
> with another name?

Forking copies of widgets off in your own library is a poor idea however
you see it. (Except for GtkText, where I would consider it a good idea,
because the widget, or anything compatible with it, simply will not be maintained
in future versions of GTK+)

If somebody improves a widget in a way that is compatible with an existing
widget, it should be included in GTK+, in most circumstances. The reasons
why not would be:

 - The feature doesn't seem generally useful. 
 - The feature would be better implemented in a different way 
   (gtk_check_button_set_style (GTK_STYLE_WINDOWS/GTK_STYLE_MOTIF) would
    NOT be accepted)
 - The code looks like it would be a maintainence problem.
 
> With gtkcheckitem I wanted to fix an alignment bug (it doesn't
> center without labels) and I needed it for my application. I
> couldn't wait until the bug is fixed for my application, and that's
> why I released it. If you tell me that this bug will be fixed for
> 1.4/2.0, I will remove it from my libraries.

Have you submitted a patch? Have you mailed a bug report? If not, it
almost certainly won't be fixed for the next release. Though I must
admit, I tend to think that user interfaces where people use a
checkbutton without a label are generally broken in one way or
another. 

(It is _not_ a good idea to decide that for your checkbuttons, the
label must go on the left because you want to line up the label
with a bunch of other labels. Stick with the standard, keep
the label on the right for checkbuttons.)

> The thing is that I got really dissapointed when I sent a patch for
> gtkscrolledwindow like 1 year ago,
> adding a shadowed border to the viewport. This would avoid having to draw
> the border for each child widget (like gtkclist, it would simplify the
> drawing code). I considered it  useful (I believe Owen did , too), but I
> haven't seen it implemented. 

It wasn't implemented, if I recall correctly,  because I considered to
close to 1.2. It's somewhere on the todo list for 1.4.

> I haven't released my own scrolledwindow,
> either :). 
> 
> What I'm triyng to say is:
> 1) Some widgets have been left without maintainance.

> 2) I'm not sure if you take contributors too seriously.

We certainly take contributors seriously. Now, it is true that we haven't
always had the resources to properly deal with all the patches we receive,
but there certainly has been no intentional neglect of them.

> 3) ... It's just my honest opinion...
> 
> I hope you didn't get my wrong, and I don't mean to be arrogant. If it
> looks like, it's probably my english :).

It's always good to get feedback. 

Regards,
                                        Owen



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]