Re: configure.guess fails after kernel2.2.5 upgrade.

"Robin P. Reagan" <> writes:

> I have a RH5.2 i586 system that I just updated the kernel to 2.2.6 (from
> 2.0.36) after upgrading to gcc 2.8.1. I went to rebuild my glib-1.2.2
> and the configure fails to guess the host type? I tried looking through
> config.guess to no avail (It does not return anything).
> I looked at my last build of gtk-1.2.1 (I had "clean"ed my glib tree) 
> and found that it was using "i586-pc-linux-gnu". Is this the correct
> host string? and why did upgrading the kernel break the config.guess?

Actually, I don't think it is a hostname problem or a kernel
problem. (I run GTK+ fine on several different 2.2.5 systems).

Rather, the problem is, I think, that you don't have a functional
'/usr/bin/cc' - and the config.guess script tries to use that
to compile a test program.

Somethign like:

 ln -s /usr/bin/gcc /usr/bin/cc

I think will help. (Or alternatively, just "export CC=gcc" if
you don't want to modify the system)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]