Re: [gtk-list] GTK installation problem !

Cyril Thibout wrote:

> Hi
> I just tried to install GTK 1.2.1 on LINUX2.0.36  with Mandrake 5.3 without
> success:
> the first phase has been successfully completed  : the GLIB 1.2.1  has been
> compiled and installed (at least no error message!)
> But when I launch the  GTK 1.2.1 " ./configure " GLIB IS SAID MISSING !
>  ("the glib- config script installed by GLIB was not be found ...")
> If I configure GTK with the --prefix option with the GLIB  full path I get
> the same error message.
> If I launch the configuration script with --with-glib option (with the
> installation glib path) the GTK configuration is ok.
> BUT when I launch the GTK make it failed because of a (written
> in the makefile !) that can't be found.
> Please let me know what I could have forgotten !
> Thanks
> Jerome

1. If you just run configure without '--prefix', it should then
   installed in /usr/local/lib (libglib* and others), /usr/local/bin
   (glib-config), and /usr/local/include (header files), check
   against this.
2. add your path with /usr/local/bin, so Gtk configure able to run
3. make sure that in /etc contains /usr/local/lib
4. run (as root) ldconfig -v, and verify whether the output really
   contain /usr/local/lib and glib libraries in it.
More or less same rule applies on Gtk. Good luck and have fun!

Best regards,
Ferri Andy Ch.

      // chandy a7 indo 607 net 607 id  -------/
    //     Linux kernel 2.2.5   XFree86
  //    Glib/Gtk 1.2.1      Enlightenment 0.16
//   Mozilla 4.51                    -------/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]