Error in installing an application whose Glib is the main issue.

Well, since I am so far at the end of the night, I'm trying to install upgrade my Debian 7.4 Wheezy, only when I try to install any package that a newer version of Glib is required, which is 2.39.90, which I have already installed the latest version, it appears telling me to uninstall the old version. However, when I go to uninstall the old version of Glib, which is 2.38.2, it says if I remove it, it will uninstall my graphical environment, where the "gnome", trailers and all other applications to it. I've tried to see if there is any command that I can update the file that indicates the latest version of Glib, but I could not. The program asks me a larger version than 2.39.5, but I do not know what to do. Can anyone help me? 

The error that is giving is:

checking for GLIB - version >= 2.39.5... 
*** 'pkg-config --modversion glib-2.0' returned 2.39.90, but GLIB (2.38.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: 
*** GLIB 2.39.5 or better is required. The latest version of
*** GLIB is always available from

Thanks for all.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]