Re: Regarding gdbus-codegen

On 18/07/2013 02:04, Fan Chun-wei wrote:

I also ran Python 2.7 in both x86 and x64 flavors in the same way Tarnyko ran the script (which I built myself using Visual Studio, so this is a native Windows build/version of Python, running under cmd.exe), and this worked for me too.

Thanks guys, that's quite interesting.

I can't quite remember where I obtained Python but the installer name seems to take the same format as the ones that are available here:-

At the time I tried versions 2.7 and 3.1 but they both gave me the same problem.  Going back to Tarnyko's email....

On 17/07/2013 19:55, Tarnyko wrote:
- in "gdbus-codegen", we have :
from codegen import codegen_main

That's a bit strange.  I don't have that first ($PATH) statement at all - but having said that, I didn't process  I simply copied it to gdbus-codegen.  Perhaps I should have run it through some processor?  Currently (on my system) gdbus-codegen is as below.


# gdbus-codegen (from my system)
import os
import sys

srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)

if srcdir is not None:
    path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
elif == 'nt':
    # Makes gdbus-codegen 'relocatable' at runtime on Windows.
    path = os.path.join(os.path.dirname(__file__), '..', 'lib', 'gdbus-2.0')
    path = os.path.join('@datadir@', 'glib-2.0')

sys.path.insert(0, os.path.abspath(path))
import codegen_main


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]