Re: [directfb-dev] gtk+ does not compile against DirectFB < 1.2.0, shall the minimum DirectFB requirements be rised accordingly?

[CC'ing also debian-boot list, since the Debian installer is one of the major GTK-DirectFB consumers and they may be interested in this thread.]

Denis Oliver Kropp ha scritto:
Attilio Fiandrotti wrote:

The minimum DirectFB requirement to build gtk+ with the DirectFB backend is currently 0.9.24


However, i noticed that some DirectFB structures and macro used in gdk/directfb/gdktestutils-directfb.c are provided only starting from DirectFB >= 1.2.0. This inconsistency (toghether with other issues i am trying to address now) prevent building gtk+ with the DirectFB backend.

How should we deal with this situation ? Shall the gtk+ code which requires DirectFB >=1.2.0 be removed from gtk+ or shall the minimum DirectFB requirements br rised to 1.2.0 ?

The requirement should be 1.0.0, but with checks where required to utilize
new features. I'd raise the required version to 1.2.0 not before one year
after its release :)

Ok, so i guess that for now this specific issue could be workarounded by means of a check on DIRECTFB_MAJOR_VERSION and DIRECTFB_MINOR_VERSION in gdktestutils-directfb.c. I also guess that the minimum DirectFB requirements could be raised to 1.0.0, since DirectFB version 1.0.1-11 is in Debian unstable (d-i folks, what's your opinion on this point ?)

BTW, any volunteers found to forward port my giant gtk+ 2.12.9 patch?

Is the patch available somewhere ? How can one get it ?

kinds regards


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]