Re: [directfb-dev] gtk+ does not compile against DirectFB < 1.2.0, shall the minimum DirectFB requirements be rised accordingly?

Attilio Fiandrotti wrote:

The minimum DirectFB requirement to build gtk+ with the DirectFB backend is currently 0.9.24


However, i noticed that some DirectFB structures and macro used in gdk/directfb/gdktestutils-directfb.c are provided only starting from DirectFB >= 1.2.0. This inconsistency (toghether with other issues i am trying to address now) prevent building gtk+ with the DirectFB backend.

How should we deal with this situation ? Shall the gtk+ code which requires DirectFB >=1.2.0 be removed from gtk+ or shall the minimum DirectFB requirements br rised to 1.2.0 ?

The requirement should be 1.0.0, but with checks where required to utilize
new features. I'd raise the required version to 1.2.0 not before one year
after its release :)

BTW, any volunteers found to forward port my giant gtk+ 2.12.9 patch?

Best regards,
  Denis Oliver Kropp

| DirectFB - Hardware accelerated graphics |
|                 |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]