Re: Move to LGPL3

On Sat, 2008-03-15 at 21:03 +0100, ext ryan lortie wrote:
> Hello.
> After some talk at the Hackfest about it, I'm writing the list to
> officially request that glib and GTK be moved to LGPL "version 3 or
> later".

IANAL and all, but here are a few points for consideration based on my
experience after being exposed to Nokia legal machinery.

     1. Changing the wording from "version 2 or later" to "version 3 or
        later" will remove the "2 or later" option. To my understanding
        changing the terms of the license text counts as relicensing.
     2. Due to the (L)GPLv2 and v3 incompatibility everything above glib
        (or gtk+) would have to be distributed under v3, which as
        already noted is a problem if you have any v2 only sources in
        any glib application. It would be a significant disruption for
        distributors to make sure all the licenses are OK.
     3. Companies are vary of GPLv3. It took a long time to begin to
        understand GPLv2, GPLv3 is still relatively more intimidating.

Tommi Komulainen                            <tommi komulainen nokia com>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]