Re: let g_warn_if_fail replace g_assert

Armin Burgmeier wrote:

I think the proposal is that g_warn_if_fail() shall return (in contrast
to g_assert(), which most of the time aborts the program), but it shall
not return from the function calling it. g_warn_if_fail() is supposed to
do exactly what its name implies: Just print a warning if a condition is
not met.

Ah, gotcha, I interpreted 'returning' as making the calling function return. Still, though, if g_warn_if_fail() prints a g_critical(), it makes more sense to me to call it g_critical_if_fail().


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]