Re: GNOME 2.11/2.12 targeting GTK+ 2.8 (ie cairo based)

On Wed, 2005-06-08 at 15:53 +0200, Alexander Larsson wrote:
> On Wed, 2005-06-08 at 13:50 +0100, Mark McLoughlin wrote:
> >   - The benefit of being able to use all the other new APIs in GTK+
> >     2.8 for GNOME 2.12
> This was the reason i brought up this with jamesh, leading to the change
> of the jhbuild modules.
> In particular, I'd like to use the new g_utf8_collate_key_for_filename()
> function from glib in nautilus. Technically I guess we could make a copy
> of this function in nautilus for now, but it would be nice to be able to
> use the glib code, and to have the same sort in the file selector.

Is it ok if nautilus depends on glib 2.8 for this? This doesn't mean we
have to use gtk+ 2.8, gtk+ 2.6 works fine with glib 2.8.

Its a bit strange as glib and gtk+ have historically released very much
in lockstep. However, nothing says this is needed.


 Alexander Larsson                                            Red Hat, Inc 
                   alexl redhat com    alla lysator liu se 
He's an underprivileged white trash paranormal investigator fleeing from a 
secret government programme. She's a blind winged archaeologist married to the 
Mob. They fight crime! 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]