Re: Is there g_write function?



On Wed, Oct 12, 2005 at 09:07:19PM -0400, Freddie Unpenstein wrote:

I must say, I wouldn't mind some of the more common functions being wrapped (if it can be done without 
excessive overhead).

I would call that bloat even if it was done with

  #define g_write write

You'd soon end up with

  #define g_COMPLETE_ISO_C_AND_POSIX_API COMPLETE_ISO_C_AND_POSIX_API

because it's equally `confusing' to mix strchr() with
g_strlcpy(), etc.

If you have to include the original standard header as well, then you end up with both sets and can (I do 
from time to time) find yourself accidentally mixing the original functions with their enhanced glib 
equivelants.

The rule is simple: functions that operate on file names are
wrapped.

Yeti


--
That's enough.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]