Re: Purified gnome libraries???

PageStream Support wrote:

Has anyone had luck using valgrind with a GTK app? I get pages of errors before I get to my code that it hardly seems worth using. Is there a trick to using it, or perhaps something is screwy with my setup.

I use valgrind all the time with g* apps.

         I get alot of theese:
==7060== Conditional jump or move depends on uninitialised value(s)
==7060== at 0x406760EA: g_object_new_valist (in /usr/lib/
         And theese:
==7060== pthread_mutex_unlock: mutex is not locked
==7060== at 0x4062427A: __pthread_mutex_unlock (in /usr/lib/valgrind/ ==7060== by 0x40627916: _IO_funlockfile (in /usr/lib/valgrind/
==7060==    by 0x408461FD: _IO_fclose (in /lib/

hehe, it does kinda seem hopeless doesn't it; I found valgrind was easy to use though, you just have to sift through the stuff you dont want to fix and fix your own code (or you could get into writing suppression files and "beautifying" your output ;-)

I havent tried the skins yet either.


> Just wondering if anyone has run the gnome/gtk/gdk/etc, libraries
> through Purify.  I'm redoing the GUI for the product I work on using
> these libraries, (on Solaris) and when I run with Purify I'm seeing
> lots and lots of problems.  Hundreds of uninitialized memory
> references
> and invalid pointer reads.  I'm also seeing random crashes, which I'm
> attributing to memory corruption from these libs, as when I
> run without
> them (the gui is soft-loadable) and use Motif instead, I don't see any
> crashes.

Probably not, Purify is a commercial application isn't it? Which goes
against the GPL ethic(s).

I think valgrind is the closest thing.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]