Re: Error in running GTK+ app in xinerama

The same error occurs when I tried to run GNOME app, e.g. gedit.  I wonder
whether my X or GNOME settings have something wrong.

Au Chi Wa

"Chi Wa Au" <cau erggroup com> writes:
When I tried to run a GTK+ app in multi-head environment (xinerama
enabled), I got the following error:

Gdk-ERROR **: BadAccess (attempt to access private resource denied)
  serial 1004 error_code 10 request_code 88 minor_code 0

The app runs OK in single-head environment.

So, does it mean GTK+ is not multi-head compatible?

Probably means a bug in something; GTK normally works with Xinerama.
Get a backtrace from the error in gdb, start the app in gdb with 'run
--sync' to make the backtrace meaningful.


---------------------------- ERG Group --------------------------
 The contents of this email and any attachments are confidential
 and may only be read by the intended recipient.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]