Re: performance issue

Hi Allin,

On Wed, 2011-04-27 at 20:23 -0400, Allin Cottrell wrote:

In working on the file I noticed a rapid degradation in
performance as the edits proceeded -- in terms of, for example,
time taken to delete small blocks of rows or to save the file.
(Note that I didn't try to save as .xlsx; I saved the modified
version in native gnumeric format from the outset.)

After a short while I was having to wait about 15 secs at 100% CPU
to delete 4 rows, or to save. I eventually gave up when I clicked
in the top left to select all cells and tried /Format/Cells... and
had to wait over a minute at 100% CPU with nothing happening (i.e.
the format dialog hadn't yet appeared).

I generally much prefer gnumeric to LibreOffice, but on this
occasion I tried the alternative, and was able to make the changes
I wanted with no appreciable latency.

This was with gnumeric 1.10.14, compiled with gcc 4.6.0, on Linux, glibc 2.13, GTK 2.24.4. I'd be happy to provide any
potentially useful diagnostics if anyone can tell me what might be

Is this the 1.10.14 release version or taken from git prior of the
release? (There have been quite a few changes affecting xlsx import in
the 1.10.14 release. So it would be nice to know whether they are in
your version.)

Do you also observe this performance hit if you disable automatic

Personally I suspect that in the xlsx import the style structure that is
usually optimized in Gnumeric is created without that optimization.

It would be great if you could file this issue in bugzilla and if you
could attach a sample file that shows this performance hit.

Thank you


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]