performance issue

A comment here from someone who is a long-time and generally very
enthusiastic gnumeric user.

A colleague recently sent me an .xlsx file that needed cleaning up
for purposes of data analysis. The file contained a single
worksheet holding a large, but not inordinate, amount of data
(roughly 250 rows by 60 columns). It was also quite "busy" in
formatting, with several colors and some regions with special
backgrounds. I wanted to edit the content of some cells, delete
some blocks of redundant rows and columns, and remove the fancy

In working on the file I noticed a rapid degradation in
performance as the edits proceeded -- in terms of, for example,
time taken to delete small blocks of rows or to save the file.
(Note that I didn't try to save as .xlsx; I saved the modified
version in native gnumeric format from the outset.)

After a short while I was having to wait about 15 secs at 100% CPU
to delete 4 rows, or to save. I eventually gave up when I clicked
in the top left to select all cells and tried /Format/Cells... and
had to wait over a minute at 100% CPU with nothing happening (i.e.
the format dialog hadn't yet appeared).

I generally much prefer gnumeric to LibreOffice, but on this
occasion I tried the alternative, and was able to make the changes
I wanted with no appreciable latency.

This was with gnumeric 1.10.14, compiled with gcc 4.6.0, on Linux, glibc 2.13, GTK 2.24.4. I'd be happy to provide any
potentially useful diagnostics if anyone can tell me what might be

Allin Cottrell
Department of Economics
Wake Forest University

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]