Re: GODataScalar, GODataVector and GODataMatrix removal

Le samedi 18 avril 2009 à 20:05 +0200, Jean Bréfort a écrit :
At the moment, I strongly disagree with this patch. Anyway, I'll take a
few hours next week to review it thoroughly.

Don't bother to review this patch set. I'll post a new one soon, which
should not change the API and leave the GODataFoo classes.



Even without that, it makes subclassing of GOData much simpler, and
avoid much of the code duplication, which is quite obvious in the
GODataVectorFoo and GODataMatrixFoo classes.

GnmGODataFoo could be merged into a single GnmGOData class.

It also helps to keep things consistent. For example,
go_data_scalar_get_str which returns a const char *, where vector and
matrix variants return char *.

They should all return char*, IMHO.


Le samedi 18 avril 2009 à 18:25 +0200, Emmanuel Pacaud a écrit :

Here's the patches that removes GODataScalar, GODataVector and
GODataMatrix and moves their functionality into GOData.

It could be possible to go further and also merge the GODataFooVal,
GODataFooStr and GnmGOFooData classes into GODataVal, GODataStr and

Comments ?

gnumeric-list mailing list
gnumeric-list gnome org

gnumeric-list mailing list
gnumeric-list gnome org

Emmanuel PACAUD
Groupe Virgo
LAPP - Laboratoire d'Annecy-le-Vieux de physique des particules
9, chemin de Bellevue - BP 110
74941 Annecy-le-Vieux CEDEX
Tél: (+33)4 50 09 55 92 ou 17 89 - Fax: (+33)4 50 27 94 95

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]