Re: Why I can't import Google AdSense CSV file???

On Fri, 11 Feb 2005 16:10:59 -0700
"Andreas J. Guelzow" <aguelzow taliesin ca> wrote:

On Fri, 2005-11-02 at 23:30 +0100, Nomine Mutato wrote:
Hi to all. I tried to build a simple analysis system for CSV report
by Google AdSense, but Gnumeric said that it can't import this file
because is unknow format.

If I do ~$ file report.csv from command line /bin/file said: 
"report.csv: MPEG ADTS, layer I, v1,  96 kBits, 44.1 kHz, Stereo"

I tried to ~$ cat report.csv | awk '{print $1,$2,$n...}' >
myreport.csv, but myreport.csv is same file of report.csv. It's a
binary file! 

If I do ~$ strings report.csv result is an empty file! 

Can you help me? I can't share my CVS file report, because Google
policy about it forbids that, but if want I can edit this by hand
with non true data, and attach this onto mail message.


CSV files (comma separated values) are text files. If you look into
the file using cat or less or more you should see straight text. If
you don't then your file is _not_ a csv file.

Google said it's a CSV file... OOo Calc open correctly this
file... I suppose it is a "CSV from Microzoz" or similar way.

I had encode head of this file with no true data:

-- cut starts below this line --
begin-base64 644 google-report
-- cut end above this line --

Cut and paste this code into your file named report.uu, and then try
from command line

~$ uudeconde -o report.csv report.uu
~$ file report.csv 

and look result. You can read this file with cat and less, but it is a
binary file!

See too: uuencode(5) uudecode(5).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]