Some problems with configure and libraries

Hi everyone.

I'm trying to update Gnumeric to 1.2.1 from 1.1.16 (default on slackware
9.0) because of a bad cut and paste bug i noticed.

I got errors at compile time:

> Requested 'libgsf-gnome-1 >= 1.8.2'
> Requested 'libgsf-1 >= 1.8.2'
> ...
> consider adjusting the PKG_CONFIG_PATH environment variable if your > > libraries are in a nonstandard prefix so pkg-config can find them.

Fact is i have those two libraries..

Had a look into /usr/lib/pkgconfig/
and the metadata files say:

Name: libgsf-gnome-1
Description: GNOME specific extensions to libgsf
Version: 1.7.2

(but i have 1.8.2)

Name: libgsf-1
Description: A library for reading and writing structured files (eg MS OLE and Zip)
Version: 1.7.2

(but i have 1.8.2)

The required libraries are in /usr/local/lib, while the old 1.7.2 are in /usr/lib

So what i did next was to

set PKG_CONFIG_PATH /usr/local/lib:/usr/lib

but it was no use.
How do i get configure to see them?

Also, do i need to remove the old gnumeric 1.1.16 files before installing 1.2.1?

Sorry i'm not so good at libraries and such things, i know my question is probably trivial..


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]