Re: python problems

On Wed, Nov 19, 2003 at 04:35:03PM +1100, Charles R. Twardy wrote:
I've been trying to pin down the problems with Python2.3 and gnumeric.
I wrote a very simple uitest plugin (attached, 'tar xvzf' in your
.gnumeric/<version>/plugins directory. When I run it normally, it works,
but complains of invalid pointers:

free(): invalid pointer 0x41363e00!
free(): invalid pointer 0x41363df0!
Added new sheet  Sheet4
free(): invalid pointer 0x41363e20!
Set text:  Sheet4
free(): invalid pointer 0x41363e10!
free(): invalid pointer 0x41363dc0!
Closed dialog box from sheet  Sheet1
free(): invalid pointer 0x41363dd0!
free(): invalid pointer 0x41363de0!

On request, I ran it through valgrind. Output attached as grindlog.

Before making the script very simple, behaviour was either a Gnumeric hang
or a segfault.


Charles R. Twardy          
Monash University          
Computer Sci. & Software Eng.
+61(3) 9905 5823 (w)  5146 (fax)

==4077== Conditional jump or move depends on uninitialised value(s)
==4077==    at 0x46A006F4: PyObject_Free (in /usr/lib/
==4077==    by 0x469FAA38: (within /usr/lib/
==4077==    by 0x46A04410: PyString_InternInPlace (in /usr/lib/
==4077==    by 0x46A044C2: PyString_InternFromString (in /usr/lib/

Please rerun with the options
    valgrind --alignment=8 --num-callers=20

and send me the results.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]