python problems

I've been trying to pin down the problems with Python2.3 and gnumeric.
I wrote a very simple uitest plugin (attached, 'tar xvzf' in your
.gnumeric/<version>/plugins directory. When I run it normally, it works,
but complains of invalid pointers:

free(): invalid pointer 0x41363e00!
free(): invalid pointer 0x41363df0!
Added new sheet  Sheet4
free(): invalid pointer 0x41363e20!
Set text:  Sheet4
free(): invalid pointer 0x41363e10!
free(): invalid pointer 0x41363dc0!
Closed dialog box from sheet  Sheet1
free(): invalid pointer 0x41363dd0!
free(): invalid pointer 0x41363de0!

On request, I ran it through valgrind. Output attached as grindlog.

Before making the script very simple, behaviour was either a Gnumeric hang
or a segfault.


Charles R. Twardy          
Monash University          
Computer Sci. & Software Eng.
+61(3) 9905 5823 (w)  5146 (fax)

Attachment: uitest.tgz
Description: GNU Unix tar archive

Attachment: grindlog
Description: Text document

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]