RE: problems with configure script and compiling on fedora 24

You were indeed correct about not having all of the development library dependencies installed. Although, in my case it wasn't the wacom stuff, but some networking and printing dev libraries (NetworkManager-glib-devel, NetworkManager-libnm--devel, libnm-gtk-devel, cups-devel, ModemManager-glib-devel, libsmbclient-devel, and cheese-libs-devel). The real breakthrough happened when I started grepping and searching the config.log for the "was not found" or "not found" messages. Once I installed those missing dependencies, the configure script was able to successfully complete its run. Thanks for pointing me in the right direction.

- Gabriel

-------- Original Message --------
Subject: Re: problems with configure script and compiling on fedora 24
From: Peter Hutterer <peter hutterer who-t net>
Date: Thu, February 16, 2017 1:19 am
To: "Gabriel M. Elder" <gabriel tekgnowsys com>
Cc: gnomecc-list gnome org

On Wed, Feb 15, 2017 at 11:21:06PM -0700, Gabriel M. Elder wrote:
> Hey all,
> I'm trying to compile gnome control center v3.20.2 on fedora 24, using
> the distro source rpm package (control-center-3.20.2-1.fc24.src.rpm). I
> finally got all the requisite development library packages installed,
> but the configure script fails with the message: "configure: error: The
> Network, Bluetooth, Printers and Wacom panels are not optional on Linux
> systems" and exit code 1. I'm running ./configure without any options;
> specifically, I'm not --enable-ing or --disable-ing anything. Shouldn't
> the "Network, Bluetooth, Printers and Wacom" stuff be enabled by
> default, and therefore just generate the Makefile? I even tried
> modifying the configure script to remove the section that's responsible
> for this. That created a Makefile, but that barely made it 10 seconds
> before bombing out with some other error when I tried to 'make' it, and
> did not appear to be inclined to include those panels anyway. What am I
> missing? What's next?

have a look at, specifically search for "have_wacom". Looks like
you may have the dependencies installed but not those for the wacom plugin.
Same for network/bluetooth/..., config.log should have some information which
one is really missing, again start your search with have_wacom.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]