Re: Building gnome-shell with normal jhbuild

On Sat, Apr 25, 2009 at 17:11, Emmanuele Bassi <ebassi linux intel com> wrote:
> please, reply to the list and not to me. I'm subscribed.

I did a reply to all so both you and the list were on the email. I
always do a reply to all. It is my understanding that mailman makes
sure that you only get one copy of the email. Did I do something

> On Sat, 2009-04-25 at 16:38 +0200, Jaap A. Haitsma wrote:
>> On Sat, Apr 25, 2009 at 15:41, Emmanuele Bassi <ebassi linux intel com> wrote:
>> > On Sat, 2009-04-25 at 15:33 +0200, Jaap A. Haitsma wrote:
>> >
>> >> I'm trying to do this but now I am running into a problem that
>> >> metacity-clutter does not want to build because Clutter-0.9.gir does
>> >> not exist. I need clutter-trunk installed because otherwise
>> >> gnome-shell does not build. The reason why Clutter-0.9.gir does not
>> >> exist seems to be that gir-repository doesn't generate the gir files
>> >> for 0.9 it only does this for 0.8
>> >>
>> >> Any suggestions?
>> >
>> > gnome-shell depends on clutter-0.9, which provides the introspection
>> > data automatically. GNOME, on the other hand, depends on clutter-0.8
>> > since it's the current stable release.
>> >
>> metacity-clutter is asking for clutter-0.9.gir
>> See my buildoutput
>> Is this a bug in metacity-clutter?
> could you please re-read what I wrote in my reply? gnome-shell depends
> on clutter-0.9; the default GNOME external modules moduleset for the
> "normal" jhbuild only provides clutter-0.8 because it's the stable
> release. while clutter-0.8 introspection data is provided by
> gir-repository, the required clutter-0.9 introspection data is provided
> by clutter-0.9 itself.
> so, in short: "normal" jhbuild does not provide the correct dependencies
> for gnome-shell. you should be using the gnome-shell moduleset, which
> lists the correct set of dependencies.
OK I think we had a misunderstanding. I had clutter-trunk built from
jhbuild. I discovered why I had the error. I did not have
gobject-introspection built when I built clutter-trunk. Building
gobject-introspection and subsequently rebuilding clutter-trunk solves
the problem I ran into.
Another issue I ran into is that I run ubuntu and ubuntu does not have
libmozjs in search path. Simply pasting the following in my
normal .jhbuildrc
# For Ubuntu Intrepid, libmozjs lives in /usr/lib/xulrunner-<version>
# However, that path isn't in, meaning that it's basically
# impossible to use the xulrunner .pc files and libraries. Work around
# this by deriving the path and adding it to LD_LIBRARY_PATH ourself.
import re
import subprocess
_pkgconfig = subprocess.Popen(['pkg-config', '--variable=sdkdir', 'mozilla-js'],
_sdkdir = _pkgconfig.communicate()[0].strip()
if _pkgconfig.returncode == 0:
    _libdir = re.sub('-(sdk|devel)', '', _sdkdir)
    if os.path.exists(_libdir + '/'):
        addpath('LD_LIBRARY_PATH', _libdir)
solves that problem

Furthermore I replaced metacity-clutter by mutter and have it depend
on clutter-trunk, and clutter-trunk depend on gobject-introspection
and everything works like a charm with normal jhbuild.

These changes are now also in the git repo of jhbuild so it should
work for everyone now when they use normal jhbuild  :-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]