Re: problem syncing on OpenSUSE 10.2

Problem solved.

given that OpenSUSE 10.1 with garnome 2.16.2 installed inside worked for
syncing..I got
to thinking why not try build the evolution- and
evolution-pilot- rpms using the
src it compiles.  so I did...

I used the spec file from the OpenSUSE 10.2 distribution and applied the
4 patches that
the garnome installer applies...took about 3 hours.

I then rpm -Uvf the 2 new rpms and I can sync my treo.  I
tried modifying
records on the treo and synchronizing - it picks em up now.

Where should I post these rpms?

others may find em helpful.


Matt Davey wrote:
>> More rule it out as being gnome-pilot or
>> gnome-pilot-conduits on the OpenSUSE 10.2,
>> I grabbed the gnome-pilot-2.0.14 and gnome-pilot-conduits-2.0.14 from
>> the garnome-2.16.2 tree
>> and compiled these on my OpenSUSE 10.2 disk, installed them using the
>> configure option used for
>> the OpenSUSE 10.2 distribution as per the .spec file for each src pkg.
>> I then copied from my OpenSUSE 10.1 home directory
>> ~/.gnome2/gnome-pilot.d/* to my OpenSUSE 10.2.
>> fired up the script to launch the dund daemon and started
>> gpilotd -d in a term window.
>> It still crashes the phone.
>> So, what does gnome-pilot (ala gpilotd) rely on that could be hosing the
>> treo??
> First of all, did you manage to sync several times in succession using
> your 10.1 installation?  Are you certain that you are syncing all
> conduits with 10.1, repeatably?  Do you have the same evolution data on
> both systems, or at least non-trivial calendar/address data on 10.1?
> Have you tried a 'synchronize' conduit setting instead of 'copy to pilot'?
> If you are still getting the DmWrite error on your treo,
> then as far as I can gather from info such as:
> the error is caused by palm-side bugs and should be triggered equally
> on 10.1 and 10.2.
> The bugs are supposedly in the layer that transparently intercepts calls
> to the legacy (pre PalmOS 5.0) PIM databases and returns data translated
> from the new, incompatible, OS5.0 data.  pilot-link and the Evo conduits
> read/write old-style data, so they use this buggy interception code on the
> treo.
> The bugs are triggered by "deleted but not archived" records.  I guess if
> you have records on the treo, and then do a 'copy to pilot' the conduit
> deletes the records on the treo, which then get cleaned up by the buggy
> code that has trouble.
> You should check to see if there are any vendor updates for your treo.
> Other things to try:
> 1. Try disabling all but one conduit, to see which conduit is causing
>    the crash.
> 2. What if you delete all data on the Palm before a sync?
> 3. What if you do copy-from-pilot or synchronize instead of
>    copy-to-pilot?
> 4. Have you tried following the dbscan instructions from DateBk5?
>    For instance, if you can use dbscan to clean up the
>    deleted-but-not-archived records, and then do 'copy-from-pilot',
>    you may avoid the DmWrite crash.
> Hope something in the above proves useful...
> Matt
> _______________________________________________
> gnome-pilot-list mailing list
> gnome-pilot-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]