Re: SLED 10 gnome-pilot doesn't communicate with my Treo 600

On Mon, 2007-01-22 at 08:57 +0000, Matt Davey wrote:
> > In a nutshell, pilot-xfer -p /dev/pilot -L works (I get a nice list of
> > all the DB's on my Palm) but gnome-pilot doesn't seem to do anything
> > during initial configuration.
> > 
> > When I run gnome-pilot I tell it my palm is on /dev/pilot, which it is,
> > and I have the necessary rights as I've changed udev to set permissions
> > of 777 on ttyUSB* devices.
> > 
> > Not sure what output to give, as no errors are produced. My phone simply
> > times out and there's no output past the point in the gnome-pilot applet
> > wizard where it tells me to turn on my palm device to read the user name
> > already stored on it.
> Okay, if you've got pilot-link working then there shouldn't be
> any big problems getting gnome-pilot to work.
> First of all, what version of gnome-pilot are you running, and what
> palm device do you have?  Does your palm device display any error
> messages or does it just sit there and time out?
> If gnome-pilot can't manage to read the user-name and device ID from your
> palm device, then it usually means that your device has a USB device/vendor
> ID pair that isn't a known device.  This could happen with a new device
> and/or an old-ish version of gnome-pilot.
> The other thing that can happen is that there are timing problems
> between the device attempting a sync and udev creating the device.
> One thing you could try, to investigate this, is to stop the hald
> process just before you start gpilotd (in then uses a different
> method of detecting USB devices).
> The best thing to do is:
> 1. exit any running gnome-pilot applet in the taskbar.
> 2. kill any running 'gpilotd' process
> 3. start 'gpilotd' by hand in a terminal window.  It usually
>    lives either in /usr/libexec or /usr/bin
> 4. Now start up gpilotd-control-applet in another terminal
>    window and try to config.
> Console messages will appear at the terminals, which may give you
> some hints.
> Also, it can be worth changing the 'timeout' value for the device
> in the configuration applet.  Settings 0, 2, 10, 100 should span
> all behaviours.
> Let us know how you get on,
> Matt
> _______________________________________________
> gnome-pilot-list mailing list
> gnome-pilot-list gnome org

I'm running gnome-pilot v2.0.13-43 on SLED 10 with all updates as at

My Palm device, a Treo 600 just sits there and times out when trying to

Well that worked! I think I know where the problem is now, but don't
know why.... gpilotd wasn't running at all so I didn't have to kill it.
Once I started it manually then the gnome-pilot applet it worked a

So now I need to figure out why this daemon process wasn't running in
the first place.

Thanks for such a clear and easy to follow reply Matt!

Stephen Carter
Retrac Networking Limited
Ph: +44 (0)7870 218 693
Fax: +44 (0)870 7060 056

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]