Re: (FreeBSD) gnome-pilot won't sync

On Thu, 2006-12-07 at 10:25 +0000, Matt Davey wrote:
> Hi Matt,

Hi.  Thanks very much for your response.  Sorry about the delay in
working on the problem again.
> On Wed, 2006-12-06 at 19:00 -0600, Matt Bourque wrote:
> > Hi, all.  I'm very new to the world of unix-like operating systems, so I
> > hope I'm able to clearly explain enough about my problem to get some
> > help.
> > 
> > I'm running FreeBSD 6.1, and would like to sync my Handspring Visor with
> > Evolution.  I can't get it to work.  I've noticed that when I press the
> > hotsync button on the visor, /dev/ugen0 pops up,
> [...]
> >  but after a few seconds
> > the visor displays a message saying the connection couldn't be
> > established.  I've also noticed that if I keep an eye on the system log,
> > I get this every time I try to sync:
> > 
> > Dec  6 18:50:02 explore kernel: ugen0: Handspring Inc Handspring Visor,
> > rev 1.00/1.00, addr 2
> > Dec  6 18:50:07 explore kernel: ugen0: at uhub0 port 1 (addr 2)
> > disconnected
> [...]
> I've no experience of gnome-pilot / pilot-link on FreeBSD, but I'll try
> and give you some pointers anyway.

> Now, on to practicalities:
> Your ugen0 device is a USB device (I believe), rather than a serial tty
> emulation device. 

My understanding is that it is a USB device, that in fact its a generic
device for which there's no specific driver installed.

>  Your first hurdle is to get the pilot-xfer utility to
> work.  If you have a properly built pilot-xfer, it should be a case of
> doing:
>     pilot-xfer -p usb: -l
> Alternatively, depending on your kernel and modules, you may have serial
> tty emulation built in.  If you have a /dev/ttyU* device, try:
>     pilot-xfer -p /dev/ttyU* -l
> You will need to start your sync before running the above command.
> If that works, great.  If not (or if you don't have pilot-xfer
> installed), you should try downloading pilot-link 0.12.1 (see
>, and build as follows:
> 1. download the tar.gz file.
> 2. unpack with 'tar xzf pilot-link-0.12.1.tar.gz' or whatever.
> 3. cd pilot-link-0.12.1
> 4. ./configure --enable-conduits --enable-libusb
> 5. make

I do have pilot-link installed from my FreeBSD ports system.  When I
tried to use it with pilot-xfer -p usb: -l or pilot-xfer pl /dev/ugen0
-l, I get:

Unable to bind to port: usb:

I think the problem may lie in it not being automatically compiles with
usb.  I'm trying to figure out how to get it to do that.  (See?  I told
you I'm brand-new to this.)  So I tried downloading it and building it
as above, which failed with the following at the end:

Making all in .
-o ../../doc/man/  ../../../doc/xml/docbook.xsl  ../../../doc/xml/pilot-link.docbook
--nonet:No such file or directory
*** Error code 1

Stop in /usr/home/matt/pilot-link-0.12.1/doc/xml.
*** Error code 1

Stop in /usr/home/matt/pilot-link-0.12.1/doc.
*** Error code 1

Stop in /usr/home/matt/pilot-link-0.12.1.
*** Error code 1

Stop in /usr/home/matt/pilot-link-0.12.1.

> Oh, and what version of pilot-link and gnome-pilot do you have
> installed?

gnome-pilot 2.0.15 and pilot-link 0.12.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]