2.8 gconf error with pam/winbind (spaces in homedir path)

Hi all,

I run a mini-lab of debian sarge/gnome desktops in our
school library. Until today we were running gnome 2.6.
These workstations auth from an NT server
(winbind/pam) on which some muppet created 600
usernames with white spaces in.

All worked well until today's upgrade to gnome 2.8.
Now only (very few) logons - those without spaces -
don't receive a gconf error. The error occurs on
logon, upon trying to start gnome, and says that gconf
cannot open a database to store settings in. Handy
gnome apps (such as the panel with all the menus) fail
to start. 

**All users without spaces are fine. All those with
spaces are hosed. Thus it seems ~/.gconf can no longer
be found if the path has a space...**

The path seems to be set in /etc/gconf/2/path and
appears to use xml to set the user's homedir.

This seems hugely significant for anyone who
authorises using winbind and wishes to use gnome.


Matt Johnson

ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]