Solved: gnome-hint/gnumeric hanging

On 1/9, I posted a message "gnome-hint woes" in which I reported that about the time I upgraded my kernel to 2.4.0, several gnome apps which had been fine before started hanging without any message when executed (gnome-hint and gnome-help-browser, later gnumeric). As I suspected, it was not the kernel that was the problem, but something else I upgraded in preparation for the new kernel. Documentation/Changes in the kernel 2.4.0 source says you need to get modutils 2.4.0. The RPM I found for that required zlib >= 1.1.3-16 and I only had 1.1.3-6 so I did that "upgrade".

I found the problem by replacing my rpm-based gnumeric, gnome-print, and libxml with versions compiled from source so I could run gnumeric under gdb to find out where it was hanging. It was in the attempted XML parsing of the "fontmap" file. Somehow (I now believe because of the faulty libz) this file had been marked internally as a "gzfile" (it was a plain uncompressed text file) and the attempt to call gzread() on this file (in xmlParserInputBufferGrow(), line 365) was where it was hanging (and using 97+% of the CPU according to top).

I went back to and noticed that the zlib-1.1.3-16 RPMs had suspiciously disappeared. But there was a 1.1.3-18 so I installed that. Now (for the first time), the "make install" of gnome-print succeeded instead of hanging on the attempt to create the fontmap file. Also, gnumeric, gnome-hint, and gnome-help-browser once again worked normally instead of hanging silently while hogging most of the CPU.

I have not proved it, but I'm pretty sure that the problem I also reported about the big helix-code install failing was due to another hang while attempting to install gnome-print (that much I do know) due again, to the hang while trying to create the fontmap file.

Thanks to Himanshu Gohel, Telsa Gwinne, and Jens Finke for helping me along.
-- David

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]