Error compiling Orbit (both .4.3 and .4.92) on AIX4.1.5

I am trying to compile GNOME for AIX, and have gotten as far as ORBit.

After configuration, I run gmake, which progresses nicely until I get to the 
interface_repository directory.  Here is gmake's output:
Making all in daemons
Making all in interface_repository
../../../src/orbit-idl-compiler/orbit-idl --nostubs --nocommon 
gmake[4]: *** [interface_repository-skels.c] Broken pipe
gmake[4]: *** Deleting file `interface_repository-skels.c'
gmake[3]: *** [all-recursive] Error 1
gmake[2]: *** [all-recursive] Error 1
gmake[1]: *** [all-recursive] Error 1
gmake: *** [all-recursive-am] Error 2

I have done this on both 0.4.3 and 0.4.92 with the same results.

If I run orbit-idl manually, The interface_repository-skels.c is terminated in 
the middle of a case statement:
           case 'r':
              switch (opname[10]) {


orbt-idl runs fine on several other .idl files though.

Anyone have any ideas?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]