Re: orbit problems :((

I had a similar problem.  I however would get up to the 
Hostname...  and it would segfault.

Someone suggested doing this:

In ORBit/src/IIOP/connection.c, try commenting out the definitions
of the macros AM() and PM(x) at the start of the source file:

#define AM() mi1 = mallinfo();
#define PM(x) mi2 = mallinfo(); printf(x ": used %d, now %d\n", \
mi2.uordblks - mi1.uordblks, mi2.uordblks);

#define AM()
#define PM(x)

and it helped, I no longer got the info, but it then just started, and
segfaulted.  I sent probably 10 messages to the list about it, got a few
replies in the end, and a few that others where having the same problem.

I ran a gdb session on a few things, and all said that it was looking for
a file that didnt exist.  I ran an strace on the apps, and it was looking
for a file with a bunch of ascii characters in the name.  I removed all
gnome/glib/gtk/imlib/orbit stuff, and tried several times, but all with
the same outcome.  I then tried installing the 0.99.2 rpms, and everthing
worked, so I ran that a few days to see what happened.  Then Miguel asked
for me to try setting a breakpoint for open() and get a good stack trace.
I removed the rpms, and compiled/installed again, but only problem was, no
segfaults anymore :(.  The only time I actually wanted segfaults, I
couldnt get em.  Now my only problem is no matter when/where/or how I
compile balsa, when it starts, and prompts for info to put in the
~/.balsarc, its trying to open A-@??%/.orbitrc/.balsarc and all the
default settings like the Trash and Outbox locations are in
A-@??%/.orbitrc/ .  I tried letting it create that, and see what happened,
but on balsa's restart, no window ever appears until i remove those
strange directories and files.  Now at least I'm not the only one having
strange as hell things happen with ORBit.  It seems you are having the
same problem I was, only I cant get it to reproduce the segfaults anymore.


 On Sat, 23 Jan 1999 wrote:

> maybe somebody could help me out with this ugly problem I'm having with
> orbit, well at least I believe its a problem. Whenever I load any gnome
> apps, panel, balsa, gnome-session, etc, they all die with this error
> # [root@mozart /]# panel
> # Unable to connect to server port 35091
> # This generally means that the program could not talk to the esound server
> # iiop_connection_init: used 0, now 169688
> # Sockstuff: used 0, now 169688
> # Hostname: used 2144, now 171832
> #
> # ** ERROR **: Unknown error on directory creation of
> # /tmp/orbit-řA@E@`/.orbitrc (No such file or directory)
> # 
> # aborting...
> # Aborted (core dumped)
> # [root@mozart /]# 
> in this case, i didn't have esd running, regardless if it is, that same
> stuff underneath occurs :(( I have the latest orbit checkedout fresh from
> the cvs server just 5 hours ago, also the latest automake,autoconf,
> libtool versions as well, also compiled the latest glib, gtk+, imlib etc
> etc etc, all from cvs just within the last 8 hours.
> I looked in /tmp and didn't find any *orbit* files at all, so i removed
> any dot files referring to gnome in my home dir, and still the problem
> exists. Anybody know what might be happening here ?
> E-Mail:
> Date: 23-Jan-99
> Time: 15:59:29
> This message was sent by XFMail
> ----------------------------------
> -- 
>         FAQ: Frequently-Asked Questions at
>          To unsubscribe: mail with 
>                        "unsubscribe" as the Subject.


If God is One, what is bad?
                -- Charles Manson

Death has been proven to be 99% fatal in laboratory rats.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]