Re: LibGTop 0.99.1 released

On Mon, Jan 04, 1999 at 03:04:23AM -0500, Marcus Brubaker wrote:
> On Mon, 4 Jan 1999, Rebecca Ore wrote:
> > I feel like a joke or something -- but I still can't get it to build.
> > Does it need LibPropList?  What is the missing 'AM_PATH_GLIB' that's not
> > found in the library?  I assume that's responsible for the build
> > failure.
> AM_PATH_GLIB is the autoconf macro used by programs to detect glib.  If
> glib is installed from source, make sure that you have the
> /prefix/share/aclocal directory included when aclocal is run from
>  Of course, you could avoid all of this by simply getting the
> tarball and using ./configure instead of ./

When I tried earlier, I tried both ways and got the same error.  Tarball
is what I downloaded.  I found the in it.  If this shouldn't
be in it, then should I take it out?

I've deleted the previous source directory and unpacked the .99.1
tarball, just ran ./configure, without any arguments.  If I get the same
error, can we can it a bug?

In my earlier letter, I deleted a part where I said that I thought it
would be well if the beta release tarballs, 0.30, 0.99.*, were ready to
build by running ./configure, and that if arguments would be needed,
that there would be mention of them in the READ.ME file.
scripts are for snapshots.  I will try to do something with the script -- read the release material, look for information on
the mailing list, run the thing and see what happens.  If running the isn't appropriate, it shouldn't be there.  If it's
appropriate under certain conditions, then I'd really be happier if I
knew what those conditions were.

Same bang, same place.  Won't work running it ./configure.  

> I'm on a RH5.1 system, feel free to email me with problems.
Um, I've posted my problems, with all the details I could give that I
thought were relevant.  If you could email me with step-by-step
instructions and also with which kernel you're using, I think that would
be better.  The problems are the same whichever way I run it.

It always ends here:

ib/gnome-libs/include -I/usr/local/lib/glib/include -I/usr/X11R6/include
-I/usr/local/lib/glib/include -I/usr/local/include -g -O2 -Wall
-Wno-unused   -I/usr/X11R6/include -DGLIBTOP_GUILE -DGLIBTOP_GUILE_NAMES
-I/usr/local/include  -DGTOPLOCALEDIR=\"/usr/local/share/locale\"
-DLIBGTOP_SERVER=\"/usr/local/bin/libgtop_server\"  -Wall -W -g -O2
-Wall -Wno-unused  -c netload.c
-DGLIBTOP_NAMES -I../.. -I../.. -I../../sysdeps/linux -I../../include
-I../../intl -I/usr/local/include -DNEED_GNOMESUPPORT_H
-I/usr/local/lib/gnome-libs/include -I/usr/local/lib/glib/include
-I/usr/X11R6/include -I/usr/local/lib/glib/include -I/usr/local/include
-g -O2 -Wall -Wno-unused -I/usr/X11R6/include -DGLIBTOP_GUILE
-DGLIBTOP_GUILE_NAMES -I/usr/local/include
-DGTOPLOCALEDIR=\"/usr/local/share/locale\" -DLIBGTOP_VERSION=\"0.99.1\"
-DLIBGTOP_SERVER=\"/usr/local/bin/libgtop_server\" -Wall -W -g -O2 -Wall
-Wno-unused -c -fPIC -DPIC netload.c
netload.c:185: parse error
make[3]: *** [netload.lo] Error 1
make[3]: Leaving directory `/home/rebecca/libgtop-0.99.1/sysdeps/linux'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/rebecca/libgtop-0.99.1/sysdeps'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rebecca/libgtop-0.99.1'
make: *** [all-recursive-am] Error 2
[rebecca@ogoense libgtop-0.99.1]$ 

Rebecca Ore
Creativity is playing with the rule sets

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]