Re: gnome & xscreensaver

> So, as I understand it, Gnome is configuring things like so:
>   * the xscreensaver daemon is launched at startup;
>   * the xscreensaver daemon is configured to run exactly one hack,
>     and that is xlock, in locking-mode (rather than draw-but-don't-
>     lock mode)
>   * the "lock" button on the panel is configured to run xlock.

in a desparate attempt to quickly do something I put in xlock for the
locking ... without looking at how the whole setup worked ... before it
wanted to call gnome-lock which does not exist ...

> In my opinion, what you should be doing is:
>   * launch xscreensaver at startup, without overriding the *programs
>     resource;
>   * make the panel "lock" button run "xscreensaver-command -lock"
>     to tell the background xscreensaver daemon to lock the screen.
> If there are particular graphics modes that xlock has that xscreensaver
> doesn't, and you want to run those as your screensaver, then you can do
> that by adding xlock to xscreensaver's list of hacks -- but in that
> case, you have to start xlock with the arguments that tell it "draw on
> the root window" and "don't lock the screen."  

I think the screensaver setup should ber redone to allow multiple
screensavers .. I don't like the way it works now ...
> By the way, I understand that you're also using xscreensaver version
> 2.16; there was a bug in that version that made Demo Mode not work
> properly with certain window managers (Miguel, this is the bug Nat
> showed me at Linux Expo.)  I fixed this in version 2.20 (version 2.21 
> is out now.)

btw ... xscreensaver has this thing that is really bothering me and
another thing which is not that bad .... sometimes if I press a key just
when it wants to start a screensaver it flickers the screen and starts
the hack on the root window erasing my background ... I haven't seen
this in the v2.20 version that I'm using now ... but when it happens
it's quite annoying ... also for some weird reason .. when the julia
screensaver runs it seems to show the cursor sometimes ... 

anyway ...


George Lebl <>
  The following implements RSA in perl and is illegal to export from the US:

          #!/bin/perl -sp0777i<X+d*lMLa^*lN%0]dsXx++lMlN/dsM0<j]dsj
          $/=unpack('H*',$_);$_=`echo 16dio\U$k"SK$/SM$n\EsN0p[lN*1

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]