gnome & xscreensaver

I ran across an interesting problem earlier this week.  I'm using the
gnome 0.20 release (with proper rh errata rpms) and I have the following
gnome items in my .xsession:

background-properties --init &
keyboard-properties --init &
mouse-properties --init &
panel &

Via the panel, I configured xscreensaver to timeout and lock the screen
after 3 minutes.  Fine and dandy.  Worked like a champ.  I left my desk in
somewhat of a hurry and fired off xlock rather than wait for xscreensaver
to kick in.  Later, I log back in and the next time xscreensaver timed
out, the screen blanked but did not lock.  Instead I got these messages in
yellow text:

xlock, could not grab keyboard! (1)
xscreensaver: child pid 6515 (xlock) exited abnormally (code 1).

Killing off xscreensaver and rerunning 'background-properties --init'
"fixes" the problem, but should this be occurring in the first place?  It
seems fairly natural to want to explicitly lock the screen rather than
wait for a timeout.  I'm using an icon on my dock to launch xlock rather
than the gnome panel.  I noticed locking the screen from the panel does
work in all cases, but the panel is usually minimized or non-existant
(sucks up too much ram for no benefit).

- cls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]