Re: Disk Eject with gnome drivemount applet

Bruno Widmann wrote:
> the way the drivemount applet works is that you have you own for each
> cdrom / floppy etc. you have on the panel. So the cdrom drive is
> allready configurable.

Ok, I see that eject can be supported that way by the current

An other thing that I'd like to see implemented in drivemount is
support for different file system types on a single drive and mount
point. This is something that isn't doable with /etc/fstab.

E.g., I have Zip disks with vfat, ext2fs and ufs file
systems. Currently, my /etc/fstab lists these potential mounts with
separate mount points (also note sdc vs. sdc4):

/dev/sdc        /mnt/nzip       ufs     defaults,noauto,ro,user 0 0
/dev/sdc4       /mnt/lzip       ext2    defaults,noauto,user    0 0
/dev/sdc4       /mnt/dzip       vfat    defaults,noauto,user    0 0

I see this as a cludge, since I would need three drivemount
applets. Instead, I'd like to have a single applet that subsequently
tries to mount either of these mounts on /mnt/zip.

I tried to implement this using wrapper scripts named mount and umount
in the path of drivemount (umount would also do an automatic eject),
but I failed to find a working solution. The mount script was quite
straightforward, umount made trouble ejecting the correct device.

The main problem was that the drivemount applet tried to resolve the
mount point (/mnt/zip) using /etc/fstab, which had to fail (/dev/sdc
against /dev/sdc4). Certainly somehow it would have been possible to
put all of the logic in the wrapper scripts and let them care for
resolving the device paths and the mount points, but that looked like
a big hack.

I don't know if this is so much an unusual situation that nobody else
faces this problem.  For me, this looks like a nice reason to
make drivemount smarter about the real mount/umount/eject process


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]